View topic - Problems Logging In?

Problems Logging In?

General Forum for Discussing All Things Albacore

Problems Logging In?

Postby waverate » Mon May 31, 2010 9:54 am

Like the rest of the USA Website, the N American Albacore Forums have migrated over to our new servers. During the migration process, we have taken the opportunity to change and upgrade the forum software.

We hope that these changes will make the N American Forums a more positive experience.

The forums are available by following the Albacore Forum link in the menu or by clicking http://usaa.albacore.org/forum.

For the smoothest transition and the greatest chance that all your existing settings and posts will be saved, we recommend the following:

1. Start the log in process into the new USAA Website by clicking on the http://usaa.albacore.org/user link in the top right corner of the page.
2. Request a new password and a new password will be mailed to you or Create a New Account. Don't worry, if you create an account with the same email address as your old account, the website will recognize that and provide you with your old account information.
3. Take the opportunity to update your Profile information. It is not completely necessary however it will help the Association keep your current information up to date. As well, USAA membership and Regatta Registrations will be much easier in the future.

The above steps should transition your information into the new website. You are free to browse to the Albacore Forum by using the link in the Menu.

If you do have any problems, close your browser and try again. If the problem still exists, send an email to webmaster@usaa.albacore.org and we will help you out immediately.
User avatar
waverate
Skipper
 
Posts: 107
Joined: Wed Jan 26, 2005 8:14 am
Location: Canada

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest